I May Need To Upgrade Soon

macbookproair

I bought the mba in 2010, just before I left Chicago. By the time I fully switched over, the previous mbp was 4 years old. So the mba is 5 years old and I use it nearly every day. The apps are getting long in the tooth now, people send me xlsx, docx, pptx and I have to use openoffice to convert before I can use my office 2003. I use photoshop cs2, and other old software. I’m still on snow leopard.

Recently I’ve noticed it to be struggling in some tasks. Firefox gobbles huge amount of memory and the fan goes crazy. If I have to temporarily reinstall flash for whatever reasons the fan goes supercrazy. Things came to a head over the weekend when I had to run a webex meeting. It’s another service, not webex, but similar. I simply could not get the meeting controls to work, it kept teling me I had to pick an application to open the controls, then it crashes. Digging through the help documentation, I found out that the minimum requirement is 10.7, although to use all functionalities I need 10.8 or newer.

So annoyed. I had to borrow mm’s mbp, albeit at 10.7 it’s only marginally newer. She was working in the uni library and wasn’t getting home till 8pm and I had to get home by 9pm. It was a rush, to meet up with her, test the mbp briefly and I had to get a taxi home. Expensive way of running that meeting.

The seeds of thought are germinating. Sooner or later all computers become obsolete. Possibly time to start thinking about replacing the mba. Another mba or the macbook. I’d love to get the mbp, it’ll be great for speed and power but too heavy. May be by next summer, see what 2016 refreshes are like.